Information Regarding the Heartbleed Bug

The news have extensively reported the OpenSSL security flaw CVE-2014-0160, otherwise known as Heartbleed which affects a large number of web servers worldwide. Rest assured that BPC and our technology partners’ servers and websites have been patched and thus secure and protected against Heartbleed. 

Experts are strongly encouraging all internet users to change their login passwords. 

For more information about the Heartbleed Bug, please visit www.heartbleed.com

 

Posted on April 11, 2014 .